UpdateEntry Method


Updates the scheme entry with the same parameter value as the input entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void UpdateEntry(
	ColorFillSchemeEntry entry
)
Visual Basic
Public Sub UpdateEntry ( _
	entry As ColorFillSchemeEntry _
)
Visual C++
public:
void UpdateEntry(
	ColorFillSchemeEntry^ entry
)

Parameters

entry
Type: Autodesk.Revit.DBColorFillSchemeEntry
The entry to be updated.

Remarks

The following entry fields can be updated:

  • Color
  • FillPattenId
  • Caption
  • IsVisible
/

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The entry does not exist or the same as input one. -or- The entry does not exist or all the updating fields are the same as existing one.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also