IsPipeTypeId Method


Pipe Is Pipe Type Id Method

Checks if given type is valid pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsPipeTypeId(
	Document document,
	ElementId pipeTypeId
)

Parameters

document Document
The document.
pipeTypeId ElementId
ElementId of the pipe type to check.

Return Value

Boolean
True if pipe type can used for this pipe, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
A type is valid for pipe if it can be used to the pipe element.
See Also