GetNodeById Method


Gets the analytical node with the specified id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public MEPAnalyticalNode GetNodeById(
	int nodeId
)
Visual Basic
Public Function GetNodeById ( _
	nodeId As Integer _
) As MEPAnalyticalNode
Visual C++
public:
MEPAnalyticalNode^ GetNodeById(
	int nodeId
)

Parameters

nodeId
Type: SystemInt32
The node identifier, be aware that this identifier may not be sequentially ordered for all analytical nodes.

Return Value

The returned analytical node.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input must be a valid node id.

See Also