GetNodeById Method


MEPAnalytical Model Data Get Node By Id Method

Gets the analytical node with the specified id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public MEPAnalyticalNode GetNodeById(
	int nodeId
)

Parameters

nodeId Int32
The node identifier, be aware that this identifier may not be sequentially ordered for all analytical nodes.

Return Value

MEPAnalyticalNode
The returned analytical node.
Exceptions
Exception Condition
ArgumentException The input must be a valid node id.
See Also