Insert Method


Inserts the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool Insert(
	string key,
	Category item
)
Visual Basic
Public Overrides Function Insert ( _
	key As String, _
	item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
	String^ key, 
	Category^ item
) override

Parameters

key
Type: SystemString
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit.DBCategory
The category to be inserted into the map.

Return Value

Whether or not the category was inserted into the map.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationExceptionAlways thrown; this list is read only.

See Also