Insert Method


Categories Insert Method

Inserts the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public override bool Insert(
	string key,
	Category item
)

Parameters

key String
The name to be used for inserting the category into the map.
item Category
The category to be inserted into the map.

Return Value

Boolean
Whether or not the category was inserted into the map.
Exceptions
Exception Condition
InvalidOperationException Always thrown; this list is read only.
See Also