Lookup Method


Finds the shared parameter element that corresponds to the given Guid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public static SharedParameterElement Lookup(
	Document document,
	Guid guidValue
)
Visual Basic
Public Shared Function Lookup ( _
	document As Document, _
	guidValue As Guid _
) As SharedParameterElement
Visual C++
public:
static SharedParameterElement^ Lookup(
	Document^ document, 
	Guid guidValue
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
guidValue
Type: SystemGuid
Shared parameter Guid.

Return Value

The retrieved shared parameter instance, or a null reference (Nothing in Visual Basic) if the matching element is not found.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also