Creates new analytical connections between the equipment connector and the nearest point on the curves.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
The document where the new elements are created.
- typeId
- Type: Autodesk.Revit.DBElementId
The type of new analytical connections.
- equipmentOpenConnectors
- Type: System.Collections.GenericIListConnector
The open equipment connectors to be analytically connected.
- curveIdsToConnect
- Type: System.Collections.GenericIListElementId
The curves which the equipment is connected to.
Return Value
The new analytical connection elements.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Invalid connection type. -or- Not all connectors support the analytical connection. -or- No connector included. -or- Not all elements are valid curve ids. -or- No curve included. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |