CreateMultipleConnections Method


MEPAnalytical Connection Create Multiple Connections Method

Creates new analytical connections between the equipment connector and the nearest point on the curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> CreateMultipleConnections(
	Document doc,
	ElementId typeId,
	IList<Connector> equipmentOpenConnectors,
	IList<ElementId> curveIdsToConnect
)

Parameters

doc Document
The document where the new elements are created.
typeId ElementId
The type of new analytical connections.
equipmentOpenConnectors IList Connector
The open equipment connectors to be analytically connected.
curveIdsToConnect IList ElementId
The curves which the equipment is connected to.

Return Value

ISet ElementId
The new analytical connection elements.
Exceptions
Exception Condition
ArgumentException Invalid connection type. -or- Not all connectors support the analytical connection. -or- No connector included. -or- Not all elements are valid curve ids. -or- No curve included.
ArgumentNullException A non-optional argument was null
See Also