GetSegmentEndPoints Method


Gets the end points of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void GetSegmentEndPoints(
	int segmentId,
	int regionId,
	out UV end1,
	out UV end2
)
Visual Basic
Public Sub GetSegmentEndPoints ( _
	segmentId As Integer, _
	regionId As Integer, _
	<OutAttribute> ByRef end1 As UV, _
	<OutAttribute> ByRef end2 As UV _
)
Visual C++
public:
void GetSegmentEndPoints(
	int segmentId, 
	int regionId, 
	[OutAttribute] UV^% end1, 
	[OutAttribute] UV^% end2
)

Parameters

segmentId
Type: SystemInt32
The segment id.
regionId
Type: SystemInt32
The region id.
end1
Type: Autodesk.Revit.DBUV%
One end point.
end2
Type: Autodesk.Revit.DBUV%
The other end point.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The segment id is invalid.
Autodesk.Revit.ExceptionsInvalidOperationException This operation is valid only for vertically compound structures.

See Also