GetSegmentEndPoints Method


Compound Structure Get Segment End Points Method

Gets the end points of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void GetSegmentEndPoints(
	int segmentId,
	int regionId,
	out UV end1,
	out UV end2
)

Parameters

segmentId Int32
The segment id.
regionId Int32
The region id.
end1 UV
One end point.
end2 UV
The other end point.
Exceptions
Exception Condition
ArgumentException The segment id is invalid.
InvalidOperationException This operation is valid only for vertically compound structures.
See Also