Compound |
Gets the end points of a segment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void GetSegmentEndPoints(
int segmentId,
int regionId,
out UV end1,
out UV end2
)
Parameters

Exception | Condition |
---|---|
ArgumentException | The segment id is invalid. |
InvalidOperationException | This operation is valid only for vertically compound structures. |