Dissolves a collection of form elements into their defining elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADoc
- Type: Autodesk.Revit.DBDocument
The document
- elements
- Type: System.Collections.GenericICollectionElementId
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.
- ProfileOriginPointSet
- Type: System.Collections.GenericICollectionElementId%
A collection of the point element ids that represent the 'origin' of the profiles
Return Value
A collection of curve element ids from the profiles and paths of the dissolved forms.Remarks
Profile origin points define the workplane of form profiles and paths and their curves. The profile origin point represents a coordinate system with an origin (reference point) which can be manipulated to move the curves of a profile together as a unit after dissolve. Profile origin points may themselves be constrained to other parts of the model or parts of the form, based on how the form was created/constructed. This is done through the reference point hosting mechanism.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The elements do not include Forms that can be dissolved. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |