DissolveForms Method (Document, ICollection(ElementId), ICollection(ElementId))


Form Utils Dissolve Forms(Document, ICollection Element Id , ICollection Element Id ) Method

Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> DissolveForms(
	Document ADoc,
	ICollection<ElementId> elements,
	out ICollection<ElementId> ProfileOriginPointSet
)

Parameters

ADoc Document
The document
elements ICollection ElementId
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.
ProfileOriginPointSet ICollection ElementId
A collection of the point element ids that represent the 'origin' of the profiles

Return Value

ICollection ElementId
A collection of curve element ids from the profiles and paths of the dissolved forms.
Exceptions
Exception Condition
ArgumentException The elements do not include Forms that can be dissolved.
ArgumentNullException A non-optional argument was null
Remarks
Profile origin points define the workplane of form profiles and paths and their curves. The profile origin point represents a coordinate system with an origin (reference point) which can be manipulated to move the curves of a profile together as a unit after dissolve. Profile origin points may themselves be constrained to other parts of the model or parts of the form, based on how the form was created/constructed. This is done through the reference point hosting mechanism.
See Also