Checks whether an accuracy is valid for a given unit.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- unitTypeId
- Type: Autodesk.Revit.DBForgeTypeId
Identifier of the unit.
- accuracy
- Type: SystemDouble
The accuracy to check.
Return Value
True if the accuracy is valid, false otherwise.Remarks
See the Accuracy property for details on valid accuracy values.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |