IsValidAccuracy Method (ForgeTypeId, Double)


Format Options Is Valid Accuracy(Forge Type Id, Double) Method

Checks whether an accuracy is valid for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidAccuracy(
	ForgeTypeId unitTypeId,
	double accuracy
)

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.
accuracy Double
The accuracy to check.

Return Value

Boolean
True if the accuracy is valid, false otherwise.
Exceptions
Exception Condition
ArgumentException unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException A non-optional argument was null
Remarks
See the Accuracy property for details on valid accuracy values.
See Also