Creates a spot light distribution object with the given values.
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- spotBeamAngle
- Type: SystemDouble
The spot beam angle as a numerical value in radians between 0 and (8/9)*PI.
- spotFieldAngle
- Type: SystemDouble
The spot field angle as a numerical value in radians between 0 and (8/9)*PI.
- tiltAngle
- Type: SystemDouble
The tilt angle as a numerical value in radians between -PI and PI.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The angle is not valid because it is not between 1.0e-2 and 160.0. -or- The angle is not valid because it is not between -180.0 and 180.0. |