Spot |
Creates a spot light distribution object with the given values.
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public SpotLightDistribution(
double spotBeamAngle,
double spotFieldAngle,
double tiltAngle
)
Parameters

Exception | Condition |
---|---|
ArgumentOutOfRangeException | The angle is not valid because it is not between 1.0e-2 and 160.0. -or- The angle is not valid because it is not between -180.0 and 180.0. |