SpotLightDistribution Constructor (Double, Double, Double)


Spot Light Distribution(Double, Double, Double) Constructor

Creates a spot light distribution object with the given values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SpotLightDistribution(
	double spotBeamAngle,
	double spotFieldAngle,
	double tiltAngle
)

Parameters

spotBeamAngle Double
The spot beam angle as a numerical value in radians between 0 and (8/9)*PI.
spotFieldAngle Double
The spot field angle as a numerical value in radians between 0 and (8/9)*PI.
tiltAngle Double
The tilt angle as a numerical value in radians between -PI and PI.
Exceptions
Exception Condition
ArgumentOutOfRangeException The angle is not valid because it is not between 1.0e-2 and 160.0. -or- The angle is not valid because it is not between -180.0 and 180.0.
See Also