Test whether two shapes have equivalent definitions by comparing the RebarShapeDefinition and MultiplanarDefinition properties.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- otherShape
- Type: Autodesk.Revit.DB.StructureRebarShape
Another shape to be compared to this one.
Return Value
True if the shape definitions match, false otherwise.Remarks
This method will return true if the definitions are exactly equivalent, or if they are equivalent but have the opposite start/end orientation. Replaces the property RebarShape.SameShapeIgnoringHooks from prior releases.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |