Rebar |
Test whether two shapes have equivalent definitions by comparing the RebarShapeDefinition and MultiplanarDefinition properties.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- otherShape RebarShape
- Another shape to be compared to this one.
Return Value
BooleanTrue if the shape definitions match, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This method will return true if the definitions are exactly equivalent, or if they are equivalent but have the opposite start/end orientation. Replaces the property RebarShape.SameShapeIgnoringHooks from prior releases.