IsSameShapeIgnoringHooks Method


Rebar Shape Is Same Shape Ignoring Hooks Method

Note: This API is now obsolete.

Test whether two shapes have equivalent definitions by comparing the RebarShapeDefinition and MultiplanarDefinition properties.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarShape.IsSameShapeIgnoringTerminations instead.")]
public bool IsSameShapeIgnoringHooks(
	RebarShape otherShape
)

Parameters

otherShape RebarShape
Another shape to be compared to this one.

Return Value

Boolean
True if the shape definitions match, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This method will return true if the definitions are exactly equivalent. The hooks, cranks, end treatments, orientations and terminations' rotation angles are ignored.
See Also