Creates a new ExternalResourceReference from the given data.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- serverId
- Type: SystemGuid
The id of the server associated with this ExternalResourceReference. The server must implement IExternalResourceServer.
- referenceInformation
- Type: System.Collections.GenericIDictionaryString, String
The (String, String) map containing reference or lookup information that will be stored in Revit.
- version
- Type: SystemString
The version of the external data.
- inSessionPath
- Type: SystemString
The path that identifies a resource in server. ExternalResourceServer must provide this path which should not contain the server name. Revit internally will construct and store the full display path which includes the server name plus this path at the time a resource is loaded into the model for use if the server is missing.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The file is not allowed to access. |