ExternalResourceReference Constructor (Guid, IDictionary(String, String), String, String)


External Resource Reference(Guid, IDictionary String, String , String, String) Constructor

Creates a new ExternalResourceReference from the given data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExternalResourceReference(
	Guid serverId,
	IDictionary<string, string> referenceInformation,
	string version,
	string inSessionPath
)

Parameters

serverId Guid
The id of the server associated with this ExternalResourceReference. The server must implement IExternalResourceServer.
referenceInformation IDictionary String , String
The (String, String) map containing reference or lookup information that will be stored in Revit.
version String
The version of the external data.
inSessionPath String
The path that identifies a resource in server. ExternalResourceServer must provide this path which should not contain the server name. Revit internally will construct and store the full display path which includes the server name plus this path at the time a resource is loaded into the model for use if the server is missing.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The file is not allowed to access.
See Also