Splits vertically one region in split crop.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- regionIndex
- Type: SystemInt32
Index of region to be split vertically (numbering starts with 0).
- topPart
- Type: SystemDouble
Relative portion of the original region to become the new top region (0 to 1).
- bottomPart
- Type: SystemDouble
Relative portion of the original region to become the new bottom region (0 to 1).
Remarks
This function splits the crop into two regions: one occupying the top quarter of the crop, and the other the bottom quarter of the crop.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The provided view region proportions are not valid. -or- The provided region index is invalid. |
Autodesk.Revit.ExceptionsInvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. -or- The view crop is already split horizontally. |