View |
Splits vertically one region in split crop.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SplitRegionVertically(
int regionIndex,
double topPart,
double bottomPart
)
Parameters

Exception | Condition |
---|---|
ArgumentException | The provided view region proportions are not valid. -or- The provided region index is invalid. |
InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. -or- The view crop is already split horizontally. |

This function splits the crop into two regions: one occupying the top quarter of the crop, and the other the bottom quarter of the crop.