SplitRegionVertically Method


View Crop Region Shape Manager Split Region Vertically Method

Splits vertically one region in split crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SplitRegionVertically(
	int regionIndex,
	double topPart,
	double bottomPart
)

Parameters

regionIndex Int32
Index of region to be split vertically (numbering starts with 0).
topPart Double
Relative portion of the original region to become the new top region (0 to 1).
bottomPart Double
Relative portion of the original region to become the new bottom region (0 to 1).
Exceptions
Exception Condition
ArgumentException The provided view region proportions are not valid. -or- The provided region index is invalid.
InvalidOperationException The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. -or- The view crop is already split horizontally.
Remarks
This function splits the crop into two regions: one occupying the top quarter of the crop, and the other the bottom quarter of the crop.
See Also