IsDefaultFamilyTypeIdValid Method


Checks whether the family type id is valid for the give family category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public bool IsDefaultFamilyTypeIdValid(
	ElementId familyCategoryId,
	ElementId familyTypeId
)
Visual Basic
Public Function IsDefaultFamilyTypeIdValid ( _
	familyCategoryId As ElementId, _
	familyTypeId As ElementId _
) As Boolean
Visual C++
public:
bool IsDefaultFamilyTypeIdValid(
	ElementId^ familyCategoryId, 
	ElementId^ familyTypeId
)

Parameters

familyCategoryId
Type: Autodesk.Revit.DBElementId
The family category id.
familyTypeId
Type: Autodesk.Revit.DBElementId
The default family type id.

Return Value

True if the family type id is valid for the give family category, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also