IsDefaultFamilyTypeIdValid Method


Document Is Default Family Type Id Valid Method

Checks whether the family type id is valid for the give family category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsDefaultFamilyTypeIdValid(
	ElementId familyCategoryId,
	ElementId familyTypeId
)

Parameters

familyCategoryId ElementId
The family category id.
familyTypeId ElementId
The default family type id.

Return Value

Boolean
True if the family type id is valid for the give family category, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also