PointLocationOnCurve Constructor


Constructs a new instance of a class, with given or default values, to place a point on a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public PointLocationOnCurve(
	PointOnCurveMeasurementType measType,
	double measValue,
	PointOnCurveMeasureFrom measFrom
)
Visual Basic
Public Sub New ( _
	measType As PointOnCurveMeasurementType, _
	measValue As Double, _
	measFrom As PointOnCurveMeasureFrom _
)
Visual C++
public:
PointLocationOnCurve(
	PointOnCurveMeasurementType measType, 
	double measValue, 
	PointOnCurveMeasureFrom measFrom
)

Parameters

measType
Type: Autodesk.Revit.DBPointOnCurveMeasurementType
measValue
Type: SystemDouble
measFrom
Type: Autodesk.Revit.DBPointOnCurveMeasureFrom

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also