Gets the set of region ids associated to a particular layer.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- layerIdx
- Type: SystemInt32
The index of a layer in this CompoundStructure.
Return Value
An array of region ids which are associated to the specified layer.Remarks
Regions are associated to layers. In a vertically compound structure, more than one region may be associated to a single layer.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The layer index is out of range. |