Compound |
Gets the set of region ids associated to a particular layer.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- layerIdx Int32
- The index of a layer in this CompoundStructure.
Return Value
IList Int32An array of region ids which are associated to the specified layer.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | The layer index is out of range. |

Regions are associated to layers. In a vertically compound structure, more than one region may be associated to a single layer.