GetRegionsAssociatedToLayer Method


Compound Structure Get Regions Associated To Layer Method

Gets the set of region ids associated to a particular layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IList<int> GetRegionsAssociatedToLayer(
	int layerIdx
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.

Return Value

IList Int32
An array of region ids which are associated to the specified layer.
Exceptions
Exception Condition
ArgumentOutOfRangeException The layer index is out of range.
Remarks
Regions are associated to layers. In a vertically compound structure, more than one region may be associated to a single layer.
See Also