GetAvaliableLayerModifierTypes Method


Gets all the avaliable layer modifier types for the layer key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static IList<ModifierType> GetAvaliableLayerModifierTypes(
	Document document,
	ExportLayerKey exportLayerKey
)
Visual Basic
Public Shared Function GetAvaliableLayerModifierTypes ( _
	document As Document, _
	exportLayerKey As ExportLayerKey _
) As IList(Of ModifierType)
Visual C++
public:
static IList<ModifierType>^ GetAvaliableLayerModifierTypes(
	Document^ document, 
	ExportLayerKey^ exportLayerKey
)

Parameters

document
Type: Autodesk.Revit.DBDocument
A Revit document to retrieve avaliable layer modifier types from.
exportLayerKey
Type: Autodesk.Revit.DBExportLayerKey
The export layer key to specify wich category and subCategory will be used to get the layer modifier types.

Return Value

The layer modifier types.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was NULL

See Also