GetAvaliableLayerModifierTypes Method


Export Layer Table Get Avaliable Layer Modifier Types Method

Gets all the avaliable layer modifier types for the layer key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ModifierType> GetAvaliableLayerModifierTypes(
	Document document,
	ExportLayerKey exportLayerKey
)

Parameters

document Document
A Revit document to retrieve avaliable layer modifier types from.
exportLayerKey ExportLayerKey
The export layer key to specify wich category and subCategory will be used to get the layer modifier types.

Return Value

IList ModifierType
The layer modifier types.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was NULL
See Also