Export |
Gets all the avaliable layer modifier types for the layer key.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static IList<ModifierType> GetAvaliableLayerModifierTypes(
Document document,
ExportLayerKey exportLayerKey
)
Parameters
- document Document
- A Revit document to retrieve avaliable layer modifier types from.
- exportLayerKey ExportLayerKey
- The export layer key to specify wich category and subCategory will be used to get the layer modifier types.
Return Value
IList ModifierTypeThe layer modifier types.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was NULL |