CircleLightShape Class


This class encapsulates a circle light shape.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public class CircleLightShape : LightShape
Visual Basic
Public Class CircleLightShape _
	Inherits LightShape
Visual C++
public ref class CircleLightShape : public LightShape

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DB.LightingLightShape
    Autodesk.Revit.DB.LightingCircleLightShape

See Also