CircleLightShape Class


Circle Light Shape Class

This class encapsulates a circle light shape.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LightShape
Autodesk.Revit.DB.Lighting CircleLightShape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CircleLightShape : LightShape

The CircleLightShape type exposes the following members.

Constructors
Name Description
Public method CircleLightShape Creates a circle light shape object with 2.0' emit diameter.
Public method CircleLightShape(CircleLightShape) Creates a copy of the given circle light shape
Public method CircleLightShape(Double) Creates a circle light shape object with the given emit diameter.
Top
Properties
Name Description
Public property EmitDiameter The emit diameter.
Top
Methods
Name Description
Top
See Also