CircleLightShape Class


Circle Light Shape Class

This class encapsulates a circle light shape.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LightShape
Autodesk.Revit.DB.Lighting CircleLightShape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CircleLightShape : LightShape

The CircleLightShape type exposes the following members.

Constructors
Name Description
Public method CircleLightShape Creates a circle light shape object with 2.0' emit diameter.
Public method CircleLightShape(CircleLightShape) Creates a copy of the given circle light shape
Public method CircleLightShape(Double) Creates a circle light shape object with the given emit diameter.
Top
Properties
Name Description
Public property EmitDiameter The emit diameter.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from LightShape )
Top
Methods
Name Description
Public method Clone Creates a copy of the LightShape derived object.
(Inherited from LightShape )
Public method Dispose
(Inherited from LightShape )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also