Circle |
This class encapsulates a circle light shape.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The CircleLightShape type exposes the following members.

Name | Description | |
---|---|---|
![]() | CircleLightShape | Creates a circle light shape object with 2.0' emit diameter. |
![]() | CircleLightShape(CircleLightShape) | Creates a copy of the given circle light shape |
![]() | CircleLightShape(Double) | Creates a circle light shape object with the given emit diameter. |

Name | Description | |
---|---|---|
![]() | EmitDiameter | The emit diameter. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LightShape ) |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape ) |
![]() | Dispose | (Inherited from LightShape ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |