Returns the offset from the center of the compound structure to the given location line value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- wallLocationLine
- Type: Autodesk.Revit.DBWallLocationLine
The alignment type of the wall's location line.
Return Value
The offset.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.ExceptionsInvalidOperationException | This operation is valid only vertically homogeneous compound structures. |