CanRemoveElementsFromAssembly Method


Identifies if provided assembly members can be removed from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool CanRemoveElementsFromAssembly(
	AssemblyInstance assemblyInstance,
	ICollection<ElementId> memberIds
)
Visual Basic
Public Shared Function CanRemoveElementsFromAssembly ( _
	assemblyInstance As AssemblyInstance, _
	memberIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanRemoveElementsFromAssembly(
	AssemblyInstance^ assemblyInstance, 
	ICollection<ElementId^>^ memberIds
)

Parameters

assemblyInstance
Type: Autodesk.Revit.DBAssemblyInstance
The assembly instance to remove elements from.
memberIds
Type: System.Collections.GenericICollectionElementId
Element ids to be tested for validity to remove from the assembly instance.

Return Value

True if all member ids are valid, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also