CanRemoveElementsFromAssembly Method


Assembly Instance Can Remove Elements From Assembly Method

Identifies if provided assembly members can be removed from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool CanRemoveElementsFromAssembly(
	AssemblyInstance assemblyInstance,
	ICollection<ElementId> memberIds
)

Parameters

assemblyInstance AssemblyInstance
The assembly instance to remove elements from.
memberIds ICollection ElementId
Element ids to be tested for validity to remove from the assembly instance.

Return Value

Boolean
True if all member ids are valid, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also