GetTypeCatalogStringForSpec Method


Gets the string used in type catalogs to identify a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static string GetTypeCatalogStringForSpec(
	ForgeTypeId specTypeId
)
Visual Basic
Public Shared Function GetTypeCatalogStringForSpec ( _
	specTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ GetTypeCatalogStringForSpec(
	ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DBForgeTypeId
Identifier of the measurable spec.

Return Value

The type catalog string, or an empty string if the measurable spec cannot be used in type catalogs.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also