GetTypeCatalogStringForSpec Method


Unit Utils Get Type Catalog String For Spec Method

Gets the string used in type catalogs to identify a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static string GetTypeCatalogStringForSpec(
	ForgeTypeId specTypeId
)

Parameters

specTypeId ForgeTypeId
Identifier of the measurable spec.

Return Value

String
The type catalog string, or an empty string if the measurable spec cannot be used in type catalogs.
Exceptions
Exception Condition
ArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException A non-optional argument was null
See Also