Unit |
Gets the string used in type catalogs to identify a given measurable spec.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- specTypeId ForgeTypeId
- Identifier of the measurable spec.
Return Value
StringThe type catalog string, or an empty string if the measurable spec cannot be used in type catalogs.

Exception | Condition |
---|---|
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). |
ArgumentNullException | A non-optional argument was null |