IsBubbleVisibleInView Method


Identifies if the bubble is visible or not in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public bool IsBubbleVisibleInView(
	DatumEnds datumEnd,
	View view
)
Visual Basic
Public Function IsBubbleVisibleInView ( _
	datumEnd As DatumEnds, _
	view As View _
) As Boolean
Visual C++
public:
bool IsBubbleVisibleInView(
	DatumEnds datumEnd, 
	View^ view
)

Parameters

datumEnd
Type: Autodesk.Revit.DBDatumEnds
The end of the datum plane.
view
Type: Autodesk.Revit.DBView
The view on which the DatumPlane shows.

Return Value

True if the bubble is visible, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The datum plane cannot be visible in the view.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException This datum plane doesn't support bubble operations.

See Also