SetCellParamIdAndCategoryId Method (Int32, Int32, ElementId, ElementId)


Sets a cell's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellParamIdAndCategoryId(
	int nRow,
	int nCol,
	ElementId paramId,
	ElementId categoryId
)
Visual Basic
Public Sub SetCellParamIdAndCategoryId ( _
	nRow As Integer, _
	nCol As Integer, _
	paramId As ElementId, _
	categoryId As ElementId _
)
Visual C++
public:
void SetCellParamIdAndCategoryId(
	int nRow, 
	int nCol, 
	ElementId^ paramId, 
	ElementId^ categoryId
)

Parameters

nRow
Type: SystemInt32
nCol
Type: SystemInt32
paramId
Type: Autodesk.Revit.DBElementId
categoryId
Type: Autodesk.Revit.DBElementId

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- The paramId or categoryId is not valid.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also