SetCellParamIdAndCategoryId Method (Int32, Int32, ElementId, ElementId)


Table Section Data Set Cell Param Id And Category Id(Int 32, Int 32, Element Id, Element Id) Method

Sets a cell's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCellParamIdAndCategoryId(
	int nRow,
	int nCol,
	ElementId paramId,
	ElementId categoryId
)

Parameters

nRow Int32
nCol Int32
paramId ElementId
categoryId ElementId
Exceptions
Exception Condition
ArgumentException The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- The paramId or categoryId is not valid.
ArgumentNullException A non-optional argument was null
See Also