ImportElements Method


Imports IFC Elements using non-open-source framework

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public IList<ElementId> ImportElements(
	Document doc,
	string file
)
Visual Basic
Public Function ImportElements ( _
	doc As Document, _
	file As String _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ ImportElements(
	Document^ doc, 
	String^ file
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
Document to receive Elements from Import
file
Type: SystemString
Full path of the file to import.

Return Value

Returns an array of ElementIds representing created Elements.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also