ImportElements Method


IFCHybrid Import Import Elements(Document, String) Method

Note: This API is now obsolete.

Imports IFC Elements using AnyCAD.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This is deprecated in Revit 2026.  Please use the importElements function with the IFCHybridImportOptions.")]
public IList<ElementId> ImportElements(
	Document doc,
	string file
)

Parameters

doc Document
Document to receive elements from the IFC file import.
file String
Full path of the file to import.

Return Value

IList ElementId
Returns an array of ElementIds representing created elements.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also